Kirix Support Forums

problems making webconnect

Please post all general questions, comments, bug reports, and any other wxWebConnect feedback here.

problems making webconnect

Postby boom on Sat Aug 29, 2009 6:26 am


as ... arted.html describes I tried to build a test-application for webconnect. But I'm stuck at the third step ("Go to /home/user/webconnect/webconnect and type make").

My Makefile (SOMETHING/wxWidgets/webconnect/Makefile) looks like this:
Code: Select all
include ../common.mak

INCLUDES = ../wxWidgets/include
CFLAGS = ${WX_CFLAGS} -g -ggdb -fno-rtti

   dom.o \
   nsimpl.o \
   promptservice.o \
   webcontrol.o \
   webframe.o \

all: libwebconnect.a

libwebconnect.a: $(OBJECTS)
   ar rc libwebconnect.a $(OBJECTS)
   ranlib libwebconnect.a

   rm -f *.o libwebconnect.a

$(OBJECTS): %.o : %.cpp
   @echo $<
   $(CPP) $(CFLAGS) $(INCLUDES) $(DEFINES) -c $<

I try to specify my include-directory for the wxWidgets-header (SOMETHING/wxWidgets/wxWidgets/include), but somehow I still get the following error:

Code: Select all
$ make > out.txt
dom.cpp:13:19: Fehler: wx/wx.h: No such file or directory
make: *** [dom.o] Fehler 1

The wx.h-header is in the directory I specified in the makefile (SOMETHING/wxWidgets/wxWidgets/include/wx/wx.h).
Why isn't it working?

Thanks for help in advance!
Registered User
Posts: 1
Joined: Sat Aug 29, 2009 6:17 am

Re: problems making webconnect

Postby gillesp on Thu Oct 08, 2009 4:56 am

Have you checked that the wx directory is accessible to your project ?
Try compiling a very simple empty application using wx to check that it works.
Registered User
Posts: 7
Joined: Tue Oct 06, 2009 10:30 am

Return to wxWebConnect Questions, Thoughts & Feedback